27
2017
09

android启动Dialog风格Activity报错:java.lang.IllegalStateException: You need to use a theme.appcompat theme

文章出处:http://blog.csdn.net/dq1005/article/details/51326668

错误描述:java.lang.IllegalStateException: You need to use a theme.appcompat theme (or descendant) with this activity

产生原因:Activity继承自AppCompatActivity而不是Activity,在style.xml中使用了不兼容的Theme。

从错误提示中提到Theme.AppCompat theme,这是因为我们的activity一定是继承了兼容包中的类,
比如我这里就无意中继承了AppCompatActivity,它来自android.support.v7.app.AppCompatActivity。
所以就要使用与其配合的AppCompat的theme才行。

解决方法:
1、使用AppCompat theme;
2、直接继承自Activity。

上一篇:Android MagicaSakura多主题框架 下一篇:Instruments 中 Leaks使用